Sublime Text 2 and the Vala programming language on elementaryOS

Today i am going to show you how to install the new beta Sublime Text 2 editor with the addition of also adding a Sublime Package to add Vala support seeing as most elementary applications are starting to be built in the Vala programming language as it is the preferred language to use for elementary OS.

First thing you will need to do is to go to Sublime Text 2 to get version 2 and click on the download link for the version that you need. In my case i will be downloading the Linux 64bit version of the current build which is at 20111 (which probably doesnt mean a whole lot at this time).

Once you have downloaded Sublime Text 2 extract it to where ever. In my case I have an Applications folder in Home which I will install it to. Then inside that folder you will see an executable file called sublime_text. Click on this as it will create a whole lot of files that you will need later on. Then close Sublime so we can install the Vala Package.

The good thing about Sublime Text 2 is that a lot of the TextMate packages are also compatible with Sublime Text 2 so go to Vala TMBundle. So you can go to this page to install the Vala package or you can continue and we will install it through Github.

If you do not have Git installed go to your terminal and type:

$ sudo apt-get install git-core

Once you have installed git go to the Sublime Packages folder and install the Vala Package.

$ cd .config/sublime-text-2/Packages/
$ git clone git://github.com/technosophos/Vala-TMBundle.git Vala</pre>

Now there we have it. Now just open up Sublime Text 2 and folders to your project and start programming in Vala with nice syntax highlight.

Comments !

social